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How to resolve SSL Error in Bold BI Deployment

Published:

Issue:

An SSL error occurred during the deployment of BoldBI.

Root Cause:

The deployment failed because an invalid SSL certificate was added to the site.

Solution:

To resolve this issue, we recommend manually deleting the configuration file and restarting the services.


Follow the steps below based on your environment to complete the deployment:

Kubernetes:

Step 1: List Running Pods
First, list the pods running for the bold-services.

kubectl get pods -n bold-services 

Step 2: Access a Pod
Enter the bash shell of any one of the pods using the following command:

kubectl exec -it [pod-name] -n bold-services – bash 

Replace [pod-name] with your actual name of the pod.

Step 3: Remove App Data Folder
Remove the app_data folder and its files.

    rm -r /application/app_data/*

Step 4: Browse Application Base URL
Browse the application base URL to recreate the configuration files.

Do not proceed to startup before completing steps 5 and 6.

Step 5: Edit Configuration
Edit the config.json file under app_data/configuration and set IgnoreSslValidation to true.

Step 6: Restart Services
Restart the services and complete the startup using the application base URL.

Docker

Step 1: List the container
First, list the container for the bold-services.

docker ps 

Step 2: Access a container
Single Container: Enter the bash shell of the container using the following command:

docker exec -it <container name or container ID > bash
Example:  docker exec -it boldbi bash 

Multi Container: Enter the bash shell of any one of the container using the following command:

docker exec -it <container name or container ID > bash

Example:  docker exec -it id-web-container bash 

Step 3: Remove App Data Folder
Remove the app_data folder and its files.

rm -r /application/app_data/* 

Step 4: Browse Application Base URL
Browse the application base URL to recreate the configuration files.

Do not proceed to startup before completing steps 5 and 6.

Step 5: Edit Configuration
Edit the config.json file under app_data/configuration and set IgnoreSslValidation to true.

Step 6: Restart Services
Restart the services and complete the startup using the application base URL.

Windows

Step 1: Navigate the below location:

C:/Bold-services/app_data/ 

Step 2: Remove App Data Folder
Remove the app_data folder and its files.

rm -r /application/app_data/* 

Step 3: Browse Application Base URL
Browse the application base URL to recreate the configuration files.

Do not proceed to startup before completing steps 4 and 5.

Step 4: Edit Configuration
Edit the config.json file under app_data/configuration and set IgnoreSslValidation to true.

Step 5: Restart Services
Restart the services and complete the startup using the application base URL.

Linux

Step 1: Navigate the below location:

/var/www/bold-services/application/app_data/ 

Step 2: Remove App Data Folder
Remove the app_data folder and its files.

rm -r /application/app_data/* 

Step 3: Browse Application Base URL
Browse the application base URL to recreate the configuration files.

Do not proceed to startup before completing steps 4 and 5.

Step 4: Edit Configuration
Edit the config.json file under app_data/configuration and set IgnoreSslValidation to true.

Step 5: Restart Services
Restart the services and complete the startup using the application base URL.

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DK
Written by Dheepa Kumar
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